const regex = new RegExp('(?(DEFINE)
(?<key>\\w+)
(?<sep>\\s*=\\s*)
(?<value>(?:(?!(?&key)(?&sep))[^()=])+)
(?<par>\\((?:[^()]+|(?&par))+\\))
)
(?P<k>(?&key))(?&sep)(?P<v>(?:(?&value)|(?&par)))', 'gm')
const str = `drop = blah blah blah something keep = bar foo nlah aaaa rename = (a=b d=e) obs=4 where = (foo > 45 and bar == 35 and (bar == 45))`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}