# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^text\t([\d.\h]+)$/array('test'=>'text', 'prices'=>[$1]);/gmu;t' <<< "text 16.11 19.22 21.33
text 17.11 23.22 25.33 27.55
text 18.11 26.22"