re = /^text\t([\d.\h]+)$/m
str = 'text 16.11 19.22 21.33
text 17.11 23.22 25.33 27.55
text 18.11 26.22'
subst = 'array(\'test\'=>\'text\', \'prices\'=>[$1]);'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result