import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^text\\t([\\d.\\h]+)$";
final String string = "text 16.11 19.22 21.33\n"
+ "text 17.11 23.22 25.33 27.55\n"
+ "text 18.11 26.22";
final String subst = "array('test'=>'text', 'prices'=>[$1]);";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}