#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mu)(?:\G(?!\A)|'prices'=>\[)[\d.]*\K\h+"
Local $sString = "array('test'=>'text', 'prices'=>[16.11 19.22 21.33]);" & @CRLF & _
"array('test'=>'text', 'prices'=>[17.11 23.22 25.33 27.55]);" & @CRLF & _
"array('test'=>'text', 'prices'=>[18.11 26.22]);"
Local $sSubst = ", "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)