import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"(?:\G(?!\A)|'prices'=>\[)[\d.]*\K\h+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
array('test'=>'text', 'prices'=>[16.11 19.22 21.33]);
array('test'=>'text', 'prices'=>[17.11 23.22 25.33 27.55]);
array('test'=>'text', 'prices'=>[18.11 26.22]);
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #", "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)