$re = '/(?:\G(?!\A)|\'prices\'=>\[)[\d.]*\K\h+/mu';
$str = 'array(\'test\'=>\'text\', \'prices\'=>[16.11 19.22 21.33]);
array(\'test\'=>\'text\', \'prices\'=>[17.11 23.22 25.33 27.55]);
array(\'test\'=>\'text\', \'prices\'=>[18.11 26.22]);';
$subst = ", ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;