using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(((--.*)|(((/\*)+?[\w\W]+?(\*/)+)))\s+(select))|^(\w*)\s*(select)";
string input = @"Select * from table
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}