re = /(?i)(((--.*)|(((\/\*)+?[\w\W]+?(\*\/)+)))\s+(select))|^(\w*)\s*(select)/
str = 'Select * from table
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end