$re = '/(?i)(((--.*)|(((/\*)+?[\w\W]+?(\*/)+)))\s+(select))|^(\w*)\s*(select)/';
$str = 'Select * from table
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);