package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?: ?)([^,]*\(.*?\)|.+?)(?: ?)(?:,|$)`)
var str = `"%s hello", \'%s world\', $foo->bar("anything", array(\'foo\' => 5 , \'bar\' => $a)),5, foo($s) ,$foo`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}