$re = '/(?: ?)([^,]*\(.*?\)|.+?)(?: ?)(?:,|$)/';
$str = '"%s hello", \\\'%s world\\\', $foo->bar("anything", array(\\\'foo\\\' => 5 , \\\'bar\\\' => $a)),5, foo($s) ,$foo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);