re = /(?: ?)([^,]*\(.*?\)|.+?)(?: ?)(?:,|$)/
str = '"%s hello", \\\'%s world\\\', $foo->bar("anything", array(\\\'foo\\\' => 5 , \\\'bar\\\' => $a)),5, foo($s) ,$foo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end