#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([#\d,]+) in ([\w\s&]+)>?([\w\s&]*)([()\w\s\d]*)"
Local $sString = "#26,968 in Office Products (See top 100)" & @CRLF & _
"#13,452 in Industrial & Scientific > Abrasive & Finishing Products" & @CRLF & _
"#99,999 in baby" & @CRLF & _
"#888 in office supplies"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")