const regex = /([#\d,]+) in ([\w\s&]+)>?([\w\s&]*)([()\w\s\d]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([#\\d,]+) in ([\\w\\s&]+)>?([\\w\\s&]*)([()\\w\\s\\d]*)', 'gm')
const str = `#26,968 in Office Products (See top 100)
#13,452 in Industrial & Scientific > Abrasive & Finishing Products
#99,999 in baby
#888 in office supplies`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}