package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([#\d,]+) in ([\w\s&]+)>?([\w\s&]*)([()\w\s\d]*)`)
var str = `#26,968 in Office Products (See top 100)
#13,452 in Industrial & Scientific > Abrasive & Finishing Products
#99,999 in baby
#888 in office supplies`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}