using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:\d+\,\s*){4}\d+),\s*(.+)";
string input = @"1, 2, 3, 4, 5, 6, 7, 8, 9, 10";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}