import Foundation
let pattern = #"((?:\d+\,\s*){4}\d+),\s*(.+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"1, 2, 3, 4, 5, 6, 7, 8, 9, 10"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}