const regex = /((?:\d+\,\s*){4}\d+),\s*(.+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:\\d+\\,\\s*){4}\\d+),\\s*(.+)', '')
const str = `1, 2, 3, 4, 5, 6, 7, 8, 9, 10`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}