#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is)E\)((?:(?!F\)).)+)"
Local $sString = "A1147/13 NOTAMN" & @CRLF & _
"Q) ESAA/QRRCH/IV/BO /AW/000/023/5933N01746E002" & @CRLF & _
"A) ESSA B) 1311140900 C) 1311211500" & @CRLF & _
"D) 14 21 0900-1500" & @CRLF & _
"E) UPPER LIMIT ES R16C KUNGSANGEN RAISED TO 2300 FT AMSL" & @CRLF & _
"REF AIP ENR 5.1" & @CRLF & _
"F) GND G) 2300FT AMSL" & @CRLF & _
"CREATED: 30 Oct 2013 10:00:00 " & @CRLF & _
"SOURCE: EUECYIYN" & @CRLF & _
"" & @CRLF & _
"A1147/13 NOTAMN" & @CRLF & _
"Q) ESAA/QRRCH/IV/BO /AW/000/023/5933N01746E002" & @CRLF & _
"A) ESSA B) 1311140900 C) 1311211500" & @CRLF & _
"D) 14 21 0900-1500" & @CRLF & _
"E) UPPER LIMIT ES R16C KUNGSANGEN RAISED TO 2300 FT AMSL" & @CRLF & _
"REF AIP ENR 5.1" & @CRLF & _
"CREATED: 30 Oct 2013 10:00:00 " & @CRLF & _
"SOURCE: EUECYIYN"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")