import re
regex = re.compile(r"E\)((?:(?!F\)).)+)", flags=re.IGNORECASE | re.DOTALL)
test_str = ("A1147/13 NOTAMN\n"
"Q) ESAA/QRRCH/IV/BO /AW/000/023/5933N01746E002\n"
"A) ESSA B) 1311140900 C) 1311211500\n"
"D) 14 21 0900-1500\n"
"E) UPPER LIMIT ES R16C KUNGSANGEN RAISED TO 2300 FT AMSL\n"
"REF AIP ENR 5.1\n"
"F) GND G) 2300FT AMSL\n"
"CREATED: 30 Oct 2013 10:00:00 \n"
"SOURCE: EUECYIYN\n\n"
"A1147/13 NOTAMN\n"
"Q) ESAA/QRRCH/IV/BO /AW/000/023/5933N01746E002\n"
"A) ESSA B) 1311140900 C) 1311211500\n"
"D) 14 21 0900-1500\n"
"E) UPPER LIMIT ES R16C KUNGSANGEN RAISED TO 2300 FT AMSL\n"
"REF AIP ENR 5.1\n"
"CREATED: 30 Oct 2013 10:00:00 \n"
"SOURCE: EUECYIYN")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")