import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "E\\)((?:(?!F\\)).)+)";
final String string = "A1147/13 NOTAMN\n"
+ "Q) ESAA/QRRCH/IV/BO /AW/000/023/5933N01746E002\n"
+ "A) ESSA B) 1311140900 C) 1311211500\n"
+ "D) 14 21 0900-1500\n"
+ "E) UPPER LIMIT ES R16C KUNGSANGEN RAISED TO 2300 FT AMSL\n"
+ "REF AIP ENR 5.1\n"
+ "F) GND G) 2300FT AMSL\n"
+ "CREATED: 30 Oct 2013 10:00:00 \n"
+ "SOURCE: EUECYIYN\n\n"
+ "A1147/13 NOTAMN\n"
+ "Q) ESAA/QRRCH/IV/BO /AW/000/023/5933N01746E002\n"
+ "A) ESSA B) 1311140900 C) 1311211500\n"
+ "D) 14 21 0900-1500\n"
+ "E) UPPER LIMIT ES R16C KUNGSANGEN RAISED TO 2300 FT AMSL\n"
+ "REF AIP ENR 5.1\n"
+ "CREATED: 30 Oct 2013 10:00:00 \n"
+ "SOURCE: EUECYIYN";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}