#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Z]{1,2}?\d{3,4}[A-Z]{1,2}$"
Local $sString = "ST078K" & @CRLF & _
"C022ZK" & @CRLF & _
"C1084A" & @CRLF & _
"H963F" & @CRLF & _
"K123AA" & @CRLF & _
"AB1234"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")