$re = '/^[A-Z]{1,2}?\d{3,4}[A-Z]{1,2}$/m';
$str = 'ST078K
C022ZK
C1084A
H963F
K123AA
AB1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);