const regex = /^[A-Z]{1,2}?\d{3,4}[A-Z]{1,2}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Z]{1,2}?\\d{3,4}[A-Z]{1,2}$', 'gm')
const str = `ST078K
C022ZK
C1084A
H963F
K123AA
AB1234`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}