package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\D*(\d+)`)
var str = `gs://dcdt_-dcm_account/dcm_account_click_2016070510_20160631_165654_2592254.csv.gz`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}