import Foundation
let pattern = #"^\D*(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"gs://dcdt_-dcm_account/dcm_account_click_2016070510_20160631_165654_2592254.csv.gz"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}