$re = '~^\D*(\d+)~';
$str = 'gs://dcdt_-dcm_account/dcm_account_click_2016070510_20160631_165654_2592254.csv.gz';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);