package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\+ ?|0{2} ?)(421|420)([1-9]\d{2} ?)(\d{3} ?)(\d{3})$`)
var str = `+421915398727`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}