const regex = /\(([A-Za-z0-9\s\'=]+)\) (and|or) \(([A-Za-z0-9\s\'=]+)\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\(([A-Za-z0-9\\s\\\'=]+)\\) (and|or) \\(([A-Za-z0-9\\s\\\'=]+)\\)', 'gm')
const str = `(Field1 = 'Value1') and (Field2 = 'Value2') and (Field3 = 'Value3')
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}