re = /\(([A-Za-z0-9\s\'=]+)\) (and|or) \(([A-Za-z0-9\s\'=]+)\)/m
str = '(Field1 = \'Value1\') and (Field2 = \'Value2\') and (Field3 = \'Value3\')
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end