import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*\\b(\\d+)\\b.*\\b\\1\\b) *[1-9]\\d* *(?:, *[1-9]\\d* *)*$";
final String string = "992,1005,1007,992,456,456,1008\n"
+ "44,1005,1110\n"
+ "13, 44 , 1005, 10078 \n"
+ "11,1203,6666\n"
+ "1,11,99,2222\n"
+ "3435\n"
+ " 1234 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}