$re = '/^(?!.*\b(\d+)\b.*\b\1\b) *[1-9]\d* *(?:, *[1-9]\d* *)*$/m';
$str = '992,1005,1007,992,456,456,1008
44,1005,1110
13, 44 , 1005, 10078
11,1203,6666
1,11,99,2222
3435
1234 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);