using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^I (?:wish |would like )(?:I could |I was able to |to be able to )(.*)";
string input = @"I wish I could fly";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}