$re = '/^I (?:wish |would like )(?:I could |I was able to |to be able to )(.*)/';
$str = 'I wish I could fly';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);