const regex = /^I (?:wish |would like )(?:I could |I was able to |to be able to )(.*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^I (?:wish |would like )(?:I could |I was able to |to be able to )(.*)', '')
const str = `I wish I could fly`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}