using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(position|top|left|bottom|right):\s?(\w*);";
string input = @"background-image: url(http://host.ru:8080/img/environment/circle_portret2.jpg); position: absolute; top: 73px; left: 93px; background-position: 0px 0px; background-repeat: initial initial; ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}