re = /(position|top|left|bottom|right):\s?(\w*);/
str = 'background-image: url(http://host.ru:8080/img/environment/circle_portret2.jpg); position: absolute; top: 73px; left: 93px; background-position: 0px 0px; background-repeat: initial initial; '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end