package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(position|top|left|bottom|right):\s?(\w*);`)
var str = `background-image: url(http://host.ru:8080/img/environment/circle_portret2.jpg); position: absolute; top: 73px; left: 93px; background-position: 0px 0px; background-repeat: initial initial; `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}