#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)<script>" & @CRLF & _
"(?:(?!</script>)[\s\S])*" & @CRLF & _
"(?:google-analytics)" & @CRLF & _
"(?:(?!</script>)[\s\S])*" & @CRLF & _
"</script>"
Local $sString = " <script src="js/min/test.min.js"></script>" & @CRLF & _
" <script>" & @CRLF & _
" $('#buttons').share({" & @CRLF & _
" networks: ['twitter']," & @CRLF & _
" });" & @CRLF & _
" </script>" & @CRLF & _
"" & @CRLF & _
" <!--[if lt IE 9]>" & @CRLF & _
" <script src="js/plugins/html5shiv.js"></script>" & @CRLF & _
" <script src="js/plugins/selectivizr.js"></script>" & @CRLF & _
" <![endif]-->" & @CRLF & _
"" & @CRLF & _
" <!-- location for site scripts -->" & @CRLF & _
" <div id="scripts">" & @CRLF & _
" <script>" & @CRLF & _
" (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){" & @CRLF & _
" (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o)," & @CRLF & _
" m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)" & @CRLF & _
" })(window,document,'script','//www.google-analytics.com/analytics.js','ga');" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" ga('create', 'UA-55555-1', 'auto', 'tracker');" & @CRLF & _
" ga('tracker.send', 'pageview');" & @CRLF & _
" </script></div> <!-- /#lpsite-scripts -->" & @CRLF & _
" <div id="lppage-scripts">" & @CRLF & _
" </div>" & @CRLF & _
" <script type="text/javascript" src="js/min/form-validation.min.js"></script>" & @CRLF & _
" " & @CRLF & _
" <script>" & @CRLF & _
" (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){" & @CRLF & _
" (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o)," & @CRLF & _
" m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)" & @CRLF & _
" })(window,document,'script','//www.google-analytics.com/analytics.js','ga');" & @CRLF & _
"" & @CRLF & _
" ga('create', 'UA-55555-1', 'auto', 'tracker');" & @CRLF & _
" ga('lptracker.send', 'pageview');" & @CRLF & _
" </script>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")