# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
<script>
(?:(?!</script>)[\s\S])*
(?:google-analytics)
(?:(?!</script>)[\s\S])*
</script>
"""
test_str = (" <script src=\"js/min/test.min.js\"></script>\n"
" <script>\n"
" $('#buttons').share({\n"
" networks: ['twitter'],\n"
" });\n"
" </script>\n\n"
" <!--[if lt IE 9]>\n"
" <script src=\"js/plugins/html5shiv.js\"></script>\n"
" <script src=\"js/plugins/selectivizr.js\"></script>\n"
" <![endif]-->\n\n"
" <!-- location for site scripts -->\n"
" <div id=\"scripts\">\n"
" <script>\n"
" (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){\n"
" (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),\n"
" m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)\n"
" })(window,document,'script','//www.google-analytics.com/analytics.js','ga');\n\n\n"
" ga('create', 'UA-55555-1', 'auto', 'tracker');\n"
" ga('tracker.send', 'pageview');\n"
" </script></div> <!-- /#lpsite-scripts -->\n"
" <div id=\"lppage-scripts\">\n"
" </div>\n"
" <script type=\"text/javascript\" src=\"js/min/form-validation.min.js\"></script>\n"
" \n"
" <script>\n"
" (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){\n"
" (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),\n"
" m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)\n"
" })(window,document,'script','//www.google-analytics.com/analytics.js','ga');\n\n"
" ga('create', 'UA-55555-1', 'auto', 'tracker');\n"
" ga('lptracker.send', 'pageview');\n"
" </script>\n\n\n")
matches = re.finditer(regex, test_str, re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.