import Foundation
let pattern = #"""
<script>
(?:(?!</script>)[\s\S])*
(?:google-analytics)
(?:(?!</script>)[\s\S])*
</script>
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = ##"""
<script src="js/min/test.min.js"></script>
<script>
$('#buttons').share({
networks: ['twitter'],
});
</script>
<!--[if lt IE 9]>
<script src="js/plugins/html5shiv.js"></script>
<script src="js/plugins/selectivizr.js"></script>
<![endif]-->
<!-- location for site scripts -->
<div id="scripts">
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
ga('create', 'UA-55555-1', 'auto', 'tracker');
ga('tracker.send', 'pageview');
</script></div> <!-- /#lpsite-scripts -->
<div id="lppage-scripts">
</div>
<script type="text/javascript" src="js/min/form-validation.min.js"></script>
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
ga('create', 'UA-55555-1', 'auto', 'tracker');
ga('lptracker.send', 'pageview');
</script>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)