using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*Hello\s*(.*?)\s*Rita";
string input = @"Hello Mr John and Hello Ms Rita";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}