$re = '/.*Hello\s*(.*?)\s*Rita/';
$str = 'Hello Mr John and Hello Ms Rita';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);