const regex = /.*Hello\s*(.*?)\s*Rita/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*Hello\\s*(.*?)\\s*Rita', '')
const str = `Hello Mr John and Hello Ms Rita`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}