package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-zA-Z]\.){2}([2-9][1-9][0-9]{2}|20([2-9][0-9]|19))@uts\.edu\.co`)
var str = `j.g.2019@uts.edu.co`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}