re = /([a-zA-Z]\.){2}([2-9][1-9][0-9]{2}|20([2-9][0-9]|19))@uts\.edu\.co/m
str = 'j.g.2019@uts.edu.co'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end