const regex = /([a-zA-Z]\.){2}([2-9][1-9][0-9]{2}|20([2-9][0-9]|19))@uts\.edu\.co/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-zA-Z]\\.){2}([2-9][1-9][0-9]{2}|20([2-9][0-9]|19))@uts\\.edu\\.co', 'gm')
const str = `j.g.2019@uts.edu.co`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}