import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "```([\\w\\W]*?)```";
final String string = "###Sample Input\n"
+ "```\n"
+ "3\n"
+ "100 400 1000 1200\n"
+ "100 450 1000 1350\n"
+ "150 400 1200 1200\n"
+ "```";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}