re = /```([\w\W]*?)```/
str = '###Sample Input
```
3
100 400 1000 1200
100 450 1000 1350
150 400 1200 1200
```'
# Print the match result
str.match(re) do |match|
puts match.to_s
end